wamp:change phpmyadmin root password

The problem:
I’ve received an email from a friend that encountered an MySQL said: #1045 - Access denied for user 'root'@'localhost' (using password: YES) error when he is trying to access his http://localhost/phpmyadmin. This happened after he tried to change ‘root’ password using phpmyadmin. It seems like phpmyadmin not changing his password correctly.

The cure:
After you’ve change your ‘root’ password using phpmyadmin, you should edit your \wamp\apps\phpmyadmin\config.inc.php

*stop all mysql services before proceed

find this line of code:

$cfg['Servers'][$i]['user'] = 'root'; // MySQL user
$cfg['Servers'][$i]['password'] = ''; // MySQL password <-- type your new root password

Restart your mysql services and you’ll able to access your phpmyadmin back :D

About these ads

24 thoughts on “wamp:change phpmyadmin root password

  1. phpMyAdmin – Error
    Cannot start session without errors, please check errors given in your PHP and/or webserver log file and configure your PHP installation properly

    I got this error while change root password and edit config.inc. How can it solve?

    Plz Help me…….

  2. ok I had the same prob. I did what you said and still got the error is there a way I can change my password that I set I’m thinking I might have hit a wrong button or something when I put it in :(

  3. Thank you for this post, it provided just the information I needed; without all the bull surrounding it.
    I thought I was going to have to reinstall wamp for a minute then!
    Thanks again,
    Matt

  4. For the people that still have this problem after changing the password in the config.inc.php…

    You need to delete your browser cache as well, then try again!

  5. This was huge help. Not to take anything away from what you wrote, but ff you could update your article to include clearing the browser cache that would be nice, as clearing the cache was the missing step that solved the problem for me.

  6. I have wamp server new version with windows 7, I don’t know what’s the problem with my wamp server..still it dowsn’t work…

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s